Symptoms
- the web interface of the Verba Recording System is unavailable
- central recording solutions for Cisco and Avaya phone systems are recording, but are not inserting calls into the call database
Cause
Due to a JDBC driver incompatibility the Verba Web Application Service and other Java-based database services are not able to connect to Microsoft SQL Server when the system is installed with Java 6 Update 29.
Resolution
The recommended Java version is Java 6 Update 23, which is provided in our current media kit.
If Java 6 Update 29 is installed on your system, please uninstall it before you install an other Java.
Warning
Until further notice, we do not recommend the use of Java versions Java 6 Update 29 or above.
According to customer feedback everything works again above Java 6 Update 29, we are soon confirming this in our test environment.
Applies to
This applies to the following versions of the Verba Recording System:
- Verba Recording System 2010 (Verba 5.0)
This also applies to
- Carin IP Call Recording 3.5
- Carin IP Call Recording 4.0
More information
This issue seems to be caused by a J6U29 change in the behaviour of the standard java.net.SocketInputStream class, that breaks the communication parts of the JDBC driver. See the related Java bug report on the Oracle Sun Developer Network: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7105007

